summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric W. Biederman <ebiederm@xmission.com>2012-12-03 14:25:25 -0800
committerSimon Horman <horms@verge.net.au>2012-12-04 09:07:34 +0900
commit1e91e0a30f2236e070b5d1fb01b2b437993d001d (patch)
treed72f1bc25caf599c85dd5a313f0dac360385e96e /configure.ac
parent66980b22cd514510c31f524ec39c03f46929b329 (diff)
kexec: Teach configure to find the strip binary.
For some reason my version of the Makefile generated by configure included the line STRIP=strp. Rerunning configure from a fresh slate did not regenerate that line so I don't know how it got there. So add the code to Makefile.in and configure.ac to autodetect the strip binary. This is needed so that we can remove from purgatory all of the relocations to sections that are not needed at runtime, by stripping out those sections. Signed-off-by: "Eric W. Biederman" <ebiederm@xmission.com> [horms@verge.net.au: Omitted white-space only change to purgatory/arch/x86_64/Makefile] Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a30c90d..a423988 100644
--- a/configure.ac
+++ b/configure.ac
@@ -142,6 +142,7 @@ AC_CHECK_PROG([SED], sed, sed, "no", [$PATH])
AC_CHECK_PROG([FIND], find, find, "no", [$PATH])
AC_CHECK_PROG([XARGS], xargs, xargs, "no", [$PATH])
AC_CHECK_PROG([DIRNAME], dirname, dirname, "no", [$PATH])
+AC_CHECK_PROG([STRIP], strip, strip, "no", [$PATH])
dnl See if I have a usable copy of zlib available
if test "$with_zlib" = yes ; then
@@ -185,6 +186,7 @@ if test "$SED" = "no"; then AC_MSG_ERROR([ sed not found]); fi
if test "$FIND" = "no"; then AC_MSG_ERROR([ find not found]); fi
if test "$XARGS" = "no"; then AC_MSG_ERROR([ xargs not found]); fi
if test "$DIRNAME" = "no"; then AC_MSG_ERROR([ dirname not found]); fi
+if test "$STRIP" = "no"; then AC_MSG_ERROR([ strip not found]); fi
dnl ---Output variables...
AC_SUBST([BUILD_CC])