summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2015-02-10 20:46:11 +0800
committerSimon Horman <horms@verge.net.au>2015-02-12 08:10:33 +0900
commit58bbd468571b3e80585e5d68e97c8d67c8ed583b (patch)
tree8455f6cd918046dda708cd6cd555b9db30f267ac /configure.ac
parentf5c40daed2ab606e3113bfc1bf214ce6ebbcc776 (diff)
configure.ac: apply necessary quotes to result of macro expansion.
This can fix the following error when searching for lzma support and while at it also apply the practice to other uses of the same pattern. checking for lzma_code in -llzma... ./configure: line 4756: ac_fn_c_try_link: command not found Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index db93331..c410e90 100644
--- a/configure.ac
+++ b/configure.ac
@@ -152,22 +152,22 @@ AC_CHECK_PROG([DIRNAME], dirname, dirname, "no", [$PATH])
dnl See if I have a usable copy of zlib available
if test "$with_zlib" = yes ; then
AC_CHECK_HEADER(zlib.h,
- AC_CHECK_LIB(z, inflateInit_, ,
- AC_MSG_NOTICE([zlib support disabled])))
+ [AC_CHECK_LIB(z, inflateInit_, ,
+ AC_MSG_NOTICE([zlib support disabled]))])
fi
dnl See if I have a usable copy of lzma available
if test "$with_lzma" = yes ; then
AC_CHECK_HEADER(lzma.h,
- AC_CHECK_LIB(lzma, lzma_code, ,
- AC_MSG_NOTICE([lzma support disabled])))
+ [AC_CHECK_LIB(lzma, lzma_code, ,
+ AC_MSG_NOTICE([lzma support disabled]))])
fi
dnl find Xen control stack libraries
if test "$with_xen" = yes ; then
AC_CHECK_HEADER(xenctrl.h,
- AC_CHECK_LIB(xenctrl, xc_kexec_load, ,
- AC_MSG_NOTICE([Xen support disabled])))
+ [AC_CHECK_LIB(xenctrl, xc_kexec_load, ,
+ AC_MSG_NOTICE([Xen support disabled]))])
fi
dnl ---Sanity checks