summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAníbal Limón <anibal.limon@linux.intel.com>2015-04-08 12:48:58 -0500
committerSimon Horman <horms@verge.net.au>2015-04-09 11:09:26 +0900
commit6eb1c19a45bc5476ee9919241426d69288f3090a (patch)
tree52918cf918a17802e24cc2cc4c34369b2fb0940f /configure.ac
parent5edcbfd1368e84fce913ceeeca7b712c524dc20d (diff)
configure.ac: Fix failure caused by x32 ABI test
When try to compile with zlib fails due to configure.ac bad expansion caused by x32 ABI test that needs AC_PROG_CC for use AC_EGREP_CPP. Signed-off-by: Aníbal Limón <anibal.limon@linux.intel.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 1ecadd5..e0b5f78 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,6 +8,7 @@ AC_INIT(kexec-tools, 2.0.10.git)
AC_CONFIG_AUX_DIR(./config)
AC_CONFIG_HEADERS([include/config.h])
AC_LANG(C)
+AC_PROG_CC
AC_DEFINE_UNQUOTED(PACKAGE_DATE, "`date '+%d %B %Y'`",
[Define to the release date of this package])
@@ -106,9 +107,6 @@ AC_ARG_WITH([booke],
dnl ---Programs
dnl To specify a different compiler, just 'export CC=/path/to/compiler'
-
-AC_PROG_CC
-
if test "${build}" != "${host}" ; then
AC_CHECK_PROGS(BUILD_CC, [${build_alias}-gcc ${build}-gcc gcc])
else