summaryrefslogtreecommitdiff
path: root/tools/perf/util/setup.py
diff options
context:
space:
mode:
authorArnaldo Carvalho de Melo <acme@infradead.org>2012-10-18 11:38:35 -0300
committerIngo Molnar <mingo@kernel.org>2012-10-20 02:43:08 +0200
commit45bff41a9a6f22af28e4ba22f83c87f619e573a8 (patch)
tree3b7b76347fe6e0f1c23352ceb0d0b70b59da5a06 /tools/perf/util/setup.py
parenta448a0318af1a11b8f54d01a349b0036a3cff965 (diff)
perf python: Properly link with libtraceevent
Namhyung Kim reported that the build fails with: GEN python/perf.so gcc: error: python_ext_build/tmp//../../libtraceevent.a: No such file or directory error: command 'gcc' failed with exit status 1 cp: cannot stat `python_ext_build/lib/perf.so': No such file or directory make: *** [python/perf.so] Error 1 We need to propagate the TE_PATH variable to the setup.py file. Reported-by: Namhyung Kim <namhyung@kernel.org> Signed-off-by: Arnaldo Carvalho de Melo <acme@redhat.com> Link: http://lkml.kernel.org/n/tip-8umiPbm4sxpknKivbjgykhut@git.kernel.org [ Fixed superfluous variable build error. ] Signed-off-by: Ingo Molnar <mingo@kernel.org>
Diffstat (limited to 'tools/perf/util/setup.py')
-rw-r--r--tools/perf/util/setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/tools/perf/util/setup.py b/tools/perf/util/setup.py
index 09c3cea95d3b..73d510269784 100644
--- a/tools/perf/util/setup.py
+++ b/tools/perf/util/setup.py
@@ -23,6 +23,7 @@ cflags += getenv('CFLAGS', '').split()
build_lib = getenv('PYTHON_EXTBUILD_LIB')
build_tmp = getenv('PYTHON_EXTBUILD_TMP')
+libtraceevent = getenv('LIBTRACEEVENT')
ext_sources = [f.strip() for f in file('util/python-ext-sources')
if len(f.strip()) > 0 and f[0] != '#']
@@ -31,7 +32,7 @@ perf = Extension('perf',
sources = ext_sources,
include_dirs = ['util/include'],
extra_compile_args = cflags,
- extra_objects = [build_tmp + '/../../libtraceevent.a'],
+ extra_objects = [libtraceevent],
)
setup(name='perf',