summaryrefslogtreecommitdiff
path: root/scripts/package/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'scripts/package/debian/rules')
-rwxr-xr-xscripts/package/debian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/scripts/package/debian/rules b/scripts/package/debian/rules
index 26bc6239e200..529b71b55efa 100755
--- a/scripts/package/debian/rules
+++ b/scripts/package/debian/rules
@@ -10,7 +10,9 @@ ifneq (,$(filter-out parallel=1,$(filter parallel=%,$(DEB_BUILD_OPTIONS))))
MAKEFLAGS += -j$(NUMJOBS)
endif
-make-opts = ARCH=$(ARCH) KERNELRELEASE=$(KERNELRELEASE)
+revision = $(lastword $(subst -, ,$(shell dpkg-parsechangelog -S Version)))
+CROSS_COMPILE ?= $(filter-out $(DEB_BUILD_GNU_TYPE)-, $(DEB_HOST_GNU_TYPE)-)
+make-opts = ARCH=$(ARCH) KERNELRELEASE=$(KERNELRELEASE) KBUILD_BUILD_VERSION=$(revision) $(addprefix CROSS_COMPILE=,$(CROSS_COMPILE))
.PHONY: binary binary-indep binary-arch
binary: binary-arch binary-indep
@@ -24,7 +26,6 @@ build: build-arch build-indep
build-indep:
build-arch:
$(MAKE) -f $(srctree)/Makefile $(make-opts) \
- $(shell $(srctree)/scripts/package/deb-build-option) \
olddefconfig all
.PHONY: clean