summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2009-02-25 20:26:05 -0800
committerDavid Schleef <ds@schleef.org>2009-02-25 20:28:07 -0800
commitea2e208cc138ca0214bd4b6bb85790da7ed85269 (patch)
treec10f4578e3f6cdf9cbe30f28e5abcfc5cb18e22a /Makefile.am
parent07d2dbfdfec75e9cded0ac90e3bb0a33929de4a1 (diff)
Change how win32/common/config.h is updated
Generate win32/common/config.h-new directly from config.h.in, using shell variables in configure and some hard-coded information. Change top-level makefile so that 'make win32-update' copies the generated file to win32/common/config.h, which we keep in source control. It's kept in source control so that the git tree is buildable from VS. This change is similar to the one recently applied to GStreamer, except that it adds a few -base specific defines.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 6187b00e..d3b5266c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -60,6 +60,8 @@ WIN32_COPY = \
win32-update:
for f in $(WIN32_COPY); do cp $$f win32/common;done
+ cp $(top_builddir)/win32/common/config.h-new \
+ $(top_srcdir)/win32/common/config.h
include $(top_srcdir)/common/coverage/lcov.mak