summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFilippo Argiolas <filippo.argiolas@gmail.com>2009-07-03 11:38:01 +0200
committerFilippo Argiolas <filippo.argiolas@gmail.com>2009-07-13 16:13:25 +0200
commit0f29d71a7db24f620d61aa92e376e974d6769d22 (patch)
treea7fddefadcec17f076fcbcb3cdfe2bc43cbf90b0 /configure.ac
parent94baad7490e1a04a2d453adac3af5a05800e6f29 (diff)
v4lsrc: optional support for device probing with gudev
Enumerate v4l devices using gudev if available. Fixes bug #583640.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da8f5395..5b9c84f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -436,6 +436,29 @@ AG_GST_CHECK_FEATURE(GST_V4L, [Video 4 Linux], video4linux, [
fi
])
+# Optional gudev for device probing
+AC_ARG_WITH([gudev],
+ AC_HELP_STRING([--with-gudev],
+ [device detection with gudev]),
+ [],
+ [with_gudev=check])
+if test x$HAVE_GST_V4L = xyes; then
+ if test x$with_gudev != xno; then
+ PKG_CHECK_MODULES(GUDEV, [ gudev-1.0 >= 143 ],
+ [ have_gudev=yes
+ AC_DEFINE(HAVE_GUDEV, 1,
+ [Whether gudev is available for device detection])
+ AC_DEFINE([G_UDEV_API_IS_SUBJECT_TO_CHANGE], 1, [I know the API is subject to change.])
+ ], [
+ have_gudev=no
+ ])
+ else
+ have_gudev=no
+ fi
+fi
+AC_SUBST(GUDEV_CFLAGS)
+AC_SUBST(GUDEV_LIBS)
+
dnl *** ext plug-ins ***
dnl keep this list sorted alphabetically !