summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules34
1 files changed, 34 insertions, 0 deletions
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..87cc2ca
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,34 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+# Debian build system is horrid - hack around it to ensure that the autoconf
+# stuff is properly up to date
+build: configure Makefile.in
+
+Makefile.in: Makefile.am
+ ./autogen.sh
+
+configure: autogen.sh configure.ac
+ ./autogen.sh
+
+override_dh_auto_install:
+ dh_auto_install --destdir=debian/tmp
+
+override_dh_install:
+ find debian/tmp -name '*.la' -delete
+ dh_install --fail-missing
+
+override_dh_strip:
+ dh_strip -plibbmm0u --dbg-package=libbmm0u-dbg
+ dh_strip -s --remaining-packages
+
+%:
+ dh $@