summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRussell King <rmk_cubox@arm.linux.org.uk>2012-10-21 16:28:28 +0100
committerRussell King <rmk@arm.linux.org.uk>2013-05-05 13:54:23 +0100
commit25c093c86964a0cd317daf437445e5de65916e13 (patch)
tree356cc253a2946787ae476d90a76bb510d764d557 /debian
Initial checkin
Signed-off-by: Russell King <rmk_cubox@arm.linux.org.uk>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control60
-rw-r--r--debian/libdrm-dove-dev.install5
-rw-r--r--debian/libdrm-dove1.install1
-rw-r--r--debian/libdrm-dove1.postinst.debhelper5
-rw-r--r--debian/libdrm-dove1.postrm.debhelper5
-rwxr-xr-xdebian/rules23
8 files changed, 105 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..70a37d8
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+libdrm-dove (1.0.0-1) unstable; urgency=low
+
+ * Initial release.
+
+ -- Russell King <rmk_cubox@arm.linux.org.uk> Tue, 9 Oct 2012 00:36:54 +0100
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..ec63514
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+9
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..6799de2
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,60 @@
+Source: libdrm-dove
+Priority: optional
+Maintainer: Russell King <rmk+cubox@arm.linux.org.uk>
+Build-Depends:
+ debhelper (>= 8.1.2ubuntu2),
+ dh-autoreconf,
+ pkg-config,
+ libdrm-dev,
+Standards-Version: 3.9.2
+Section: libs
+
+Package: libdrm-dove-dev
+Section: libdevel
+Architecture: any
+Depends:
+ libdrm-dove1 (= ${binary:Version}),
+ ${misc:Depends},
+Description: Userspace interface to kernel DRM services -- development files
+ This library implements the userspace interface to the kernel DRM
+ services. DRM stands for "Direct Rendering Manager", which is the
+ kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
+ The DRI is currently used on Linux to provide hardware-accelerated
+ OpenGL drivers.
+ .
+ This package provides the development environment for libdrm-dove1.
+
+Package: libdrm-dove1
+Section: libs
+Priority: extra
+Architecture: linux-any
+Depends:
+ ${shlibs:Depends},
+ ${misc:Depends},
+Multi-Arch: same
+Pre-Depends: ${misc:Pre-Depends}
+Description: Userspace interface to kernel DRM services -- runtime
+ This library implements the userspace interface to the kernel DRM
+ services. DRM stands for "Direct Rendering Manager", which is the
+ kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
+ The DRI is currently used on Linux to provide hardware-accelerated
+ OpenGL drivers.
+ .
+ This package provides the runtime environment for libdrm-dove1.
+
+Package: libdrm-dove1-dbg
+Section: debug
+Priority: extra
+Architecture: linux-any
+Depends:
+ libdrm2 (= ${binary:Version}),
+ ${misc:Depends},
+Multi-Arch: same
+Description: Userspace interface to kernel DRM services -- debugging symbols
+ This library implements the userspace interface to the kernel DRM
+ services. DRM stands for "Direct Rendering Manager", which is the
+ kernelspace portion of the "Direct Rendering Infrastructure" (DRI).
+ The DRI is currently used on Linux to provide hardware-accelerated
+ OpenGL drivers.
+ .
+ This package provides debugging symbols for the libdrm-dove1 package.
diff --git a/debian/libdrm-dove-dev.install b/debian/libdrm-dove-dev.install
new file mode 100644
index 0000000..757f698
--- /dev/null
+++ b/debian/libdrm-dove-dev.install
@@ -0,0 +1,5 @@
+usr/include/*
+usr/lib/*/lib*.a
+usr/lib/*/lib*.so
+usr/lib/*/pkgconfig/*
+
diff --git a/debian/libdrm-dove1.install b/debian/libdrm-dove1.install
new file mode 100644
index 0000000..99c7f23
--- /dev/null
+++ b/debian/libdrm-dove1.install
@@ -0,0 +1 @@
+usr/lib/*/libdrm_dove.so.1*
diff --git a/debian/libdrm-dove1.postinst.debhelper b/debian/libdrm-dove1.postinst.debhelper
new file mode 100644
index 0000000..3d89d3e
--- /dev/null
+++ b/debian/libdrm-dove1.postinst.debhelper
@@ -0,0 +1,5 @@
+# Automatically added by dh_makeshlibs
+if [ "$1" = "configure" ]; then
+ ldconfig
+fi
+# End automatically added section
diff --git a/debian/libdrm-dove1.postrm.debhelper b/debian/libdrm-dove1.postrm.debhelper
new file mode 100644
index 0000000..7f44047
--- /dev/null
+++ b/debian/libdrm-dove1.postrm.debhelper
@@ -0,0 +1,5 @@
+# Automatically added by dh_makeshlibs
+if [ "$1" = "remove" ]; then
+ ldconfig
+fi
+# End automatically added section
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..00c9b22
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,23 @@
+#!/usr/bin/make -f
+
+###
+### Actual build
+###
+
+override_dh_auto_configure:
+ dh_auto_configure -- --enable-static=yes
+
+override_dh_auto_install:
+ dh_auto_install --destdir=debian/tmp
+
+override_dh_install:
+ find debian/tmp -name '*.la' -delete
+ dh_install --fail-missing
+
+override_dh_strip:
+ dh_strip -plibdrm-dove1 --dbg-package=libdrm-dove1-dbg
+ dh_strip -s --remaining-packages
+
+%:
+ dh $@ --with quilt,autoreconf --builddirectory=build/
+