summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Vrabel <david.vrabel@citrix.com>2013-11-06 14:55:19 +0000
committerSimon Horman <horms@verge.net.au>2013-11-19 10:20:45 +0900
commit76b4aca8850b8d438fa9bfec96cad522bdabfc2c (patch)
tree6f20da58388b4ca68476001133a4f9397364226c /configure.ac
parent75efb890f9033302d9bf27bace6268850c8a7371 (diff)
kexec/xen: require libxc from Xen 4.4
libxc from Xen 4.4 added xc_kexec_load() which will be required to load images into Xen in the future. Remove all the #ifdef'ery for older versions of libxc. Signed-off-by: David Vrabel <david.vrabel@citrix.com> Reviewed-by: Daniel Kiper <daniel.kiper@oracle.com> Signed-off-by: Simon Horman <horms@verge.net.au>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 1 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 76126cc..50a494e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -166,11 +166,8 @@ fi
dnl find Xen control stack libraries
if test "$with_xen" = yes ; then
AC_CHECK_HEADER(xenctrl.h,
- AC_CHECK_LIB(xenctrl, xc_version, ,
+ AC_CHECK_LIB(xenctrl, xc_kexec_load, ,
AC_MSG_NOTICE([Xen support disabled])))
- if test "$ac_cv_lib_xenctrl_xc_version" = yes ; then
- AC_CHECK_FUNCS(xc_get_machine_memory_map)
- fi
fi
dnl ---Sanity checks