summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormichael <michael@82007160-df01-0410-b94d-b575c5fd34c7>2013-01-16 18:30:52 +0000
committermichael <michael@82007160-df01-0410-b94d-b575c5fd34c7>2013-01-16 18:30:52 +0000
commit83f7ffe7e5cb8110964209e86ce8e44b11f4088d (patch)
treefa1f4842002862f58a04f01dcf9675a1b206e5b2 /configure.ac
parentb0f035dd5ef59e0f9096b5e716411bbb7b5afa24 (diff)
- Forward-port -r1750 [IMPORTANT: nick and topic lengths are now configurable
via ircd.conf. A max_nick_length, as well as a max_topic_length configuration option can now be found in the serverinfo{} block] - OpenSSL 0.9.8s and higher is now required in order to enable ssl support git-svn-id: svn://svn.ircd-hybrid.org/svnroot/ircd-hybrid/trunk@1751 82007160-df01-0410-b94d-b575c5fd34c7
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 3 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8ee832b..fdec15c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5,7 +5,7 @@ AC_REVISION([$Id$])
AC_PREREQ(2.69)
AC_INIT([ircd-hybrid], [TRUNK], [bugs@ircd-hybrid.org])
-AM_INIT_AUTOMAKE(1.13)
+AM_INIT_AUTOMAKE(1.13.1)
AM_MAINTAINER_MODE
AC_CONFIG_HEADER(config.h)
AC_CONFIG_SRCDIR(src/ircd.c)
@@ -117,12 +117,12 @@ else
fi
AS_IF([test "$cf_enable_openssl" != "no"],
- [AC_MSG_CHECKING(for OpenSSL 0.9.8 or above)
+ [AC_MSG_CHECKING(for OpenSSL 0.9.8s or above)
AC_RUN_IFELSE([
AC_LANG_PROGRAM([
#include <openssl/opensslv.h>
#include <stdlib.h>],
- [[ exit(!(OPENSSL_VERSION_NUMBER >= 0x00908000)); ]])],
+ [[ exit(!(OPENSSL_VERSION_NUMBER >= 0x0090813f)); ]])],
[cf_openssl_version_ok=yes],
[cf_openssl_version_ok=no],
[cf_openssl_version_ok=no])
@@ -161,8 +161,6 @@ AC_DEFINE([MP_CHUNK_SIZE_WATCH], 4*1024, [Size of the watch mempool chunk.])
# Argument processing.
AX_ARG_ENABLE_IOLOOP_MECHANISM
-AX_ARG_WITH_NICKLEN
-AX_ARG_WITH_TOPICLEN
AX_ARG_ENABLE_HALFOPS
AX_ARG_ENABLE_DEBUGGING
AX_ARG_ENABLE_WARNINGS